wok rev 23097

updated libqwt5-qt4 and libqwt5-qt4-dev (5.2.0 -> 5.2.3)
author Hans-G?nter Theisgen
date Thu Mar 12 06:52:43 2020 +0100 (6 months ago)
parents 8326b3115047
children 9cb37f5af1e5
files libqwt5-qt4-dev/receipt libqwt5-qt4/receipt
line diff
     1.1 --- a/libqwt5-qt4-dev/receipt	Wed Mar 11 17:47:33 2020 +0100
     1.2 +++ b/libqwt5-qt4-dev/receipt	Thu Mar 12 06:52:43 2020 +0100
     1.3 @@ -1,13 +1,14 @@
     1.4  # SliTaz package receipt.
     1.5  
     1.6  PACKAGE="libqwt5-qt4-dev"
     1.7 -VERSION="5.2.0"
     1.8 +VERSION="5.2.3"
     1.9  CATEGORY="development"
    1.10 -SHORT_DESC="Lib Qt Widgets for Technical applications"
    1.11 +SHORT_DESC="Lib Qt Widgets for Technical applications - development files."
    1.12  MAINTAINER="slitaz@objectif-securite.ch"
    1.13  LICENSE="LGPL2.1"
    1.14 -DEPENDS="qt-x11-opensource-src libqwt5-qt4"
    1.15 -WEB_SITE="http://qwt.sourceforge.net"
    1.16 +WEB_SITE="https://qwt.sourceforge.io"
    1.17 +
    1.18 +DEPENDS="libqwt5-qt4 qt-x11-opensource-src"
    1.19  WANTED="libqwt5-qt4"
    1.20  
    1.21  # Rules to gen a SliTaz package suitable for Tazpkg.
     2.1 --- a/libqwt5-qt4/receipt	Wed Mar 11 17:47:33 2020 +0100
     2.2 +++ b/libqwt5-qt4/receipt	Thu Mar 12 06:52:43 2020 +0100
     2.3 @@ -1,24 +1,25 @@
     2.4  # SliTaz package receipt.
     2.5  
     2.6  PACKAGE="libqwt5-qt4"
     2.7 -VERSION="5.2.0"
     2.8 +VERSION="5.2.3"
     2.9  CATEGORY="graphics"
    2.10 -SHORT_DESC="Lib Qt Widgets for Technical applications"
    2.11 +SHORT_DESC="Lib Qt Widgets for Technical applications."
    2.12  MAINTAINER="slitaz@objectif-securite.ch"
    2.13  LICENSE="LGPL2.1"
    2.14 +WEB_SITE="https://qwt.sourceforge.io"
    2.15 +
    2.16  SOURCE="qwt"
    2.17  TARBALL="$SOURCE-$VERSION.tar.bz2"
    2.18 -WEB_SITE="http://qwt.sourceforge.net"
    2.19  WGET_URL="http://switch.dl.sourceforge.net/sourceforge/qwt/$TARBALL"
    2.20 +WGET_URL="$SF_MIRROR/$SOURCE/$TARBALL"
    2.21  
    2.22 -DEPENDS="libQtCore libQtGui libQtScript libQtXml libQtDesigner gcc-lib-base"
    2.23 -BUILD_DEPENDS="$DEPENDS qt4 qmake Qt4-dev"
    2.24 +DEPENDS="gcc-lib-base libQtCore libQtDesigner libQtGui libQtScript libQtXml"
    2.25 +BUILD_DEPENDS="$DEPENDS qmake qt4 Qt4-dev"
    2.26  
    2.27  # Rules to configure and make the package.
    2.28  compile_rules()
    2.29  {
    2.30 -	cd $src
    2.31 -	qmake
    2.32 +	qmake &&
    2.33  	make -j1 &&
    2.34  	make INSTALL_ROOT=$DESTDIR install
    2.35  }
    2.36 @@ -27,6 +28,8 @@
    2.37  genpkg_rules()
    2.38  {
    2.39  	mkdir -p $fs/usr/lib
    2.40 -	cp -a $install/usr/lib/qt $fs/usr/lib
    2.41 -	cp -a $install/usr/local/qwt-$VERSION/lib/libqwt.so* $fs/usr/lib
    2.42 +
    2.43 +	cp -a $install/usr/lib/qt	$fs/usr/lib
    2.44 +	cp -a $install/usr/local/qwt-$VERSION/lib/libqwt.so* \
    2.45 +					$fs/usr/lib
    2.46  }