wok rev 24885

updated mcabber (0.9.10 -> 1.1.2)
author Hans-G?nter Theisgen
date Fri Apr 01 07:52:41 2022 +0100 (8 months ago)
parents 622f3fed2557
children 496ecfe17240
files mcabber/description.txt mcabber/receipt
line diff
     1.1 --- /dev/null	Thu Jan 01 00:00:00 1970 +0000
     1.2 +++ b/mcabber/description.txt	Fri Apr 01 07:52:41 2022 +0100
     1.3 @@ -0,0 +1,5 @@
     1.4 +Mcabber is a small XMPP (Jabber) console client.
     1.5 +Mcabber includes features such as SASL/SSL/TLS support,
     1.6 +MUC (Multi-User Chat) support, history logging, command completion,
     1.7 +OpenPGP encryption, OTR (Off-the-Record Messaging) support,
     1.8 +dynamic modules and external action triggers.
     2.1 --- a/mcabber/receipt	Fri Apr 01 07:42:28 2022 +0100
     2.2 +++ b/mcabber/receipt	Fri Apr 01 07:52:41 2022 +0100
     2.3 @@ -1,17 +1,19 @@
     2.4  # SliTaz package receipt.
     2.5  
     2.6  PACKAGE="mcabber"
     2.7 -VERSION="0.9.10"
     2.8 +VERSION="1.1.2"
     2.9  CATEGORY="network"
    2.10  SHORT_DESC="Jabber console client."
    2.11  MAINTAINER="pascal.bellard@slitaz.org"
    2.12  LICENSE="GPL2"
    2.13 +WEB_SITE="https://mcabber.com/"
    2.14 +
    2.15  TARBALL="$PACKAGE-$VERSION.tar.bz2"
    2.16 -WEB_SITE="http://lilotux.net/~mikael/mcabber"
    2.17 -WGET_URL="$WEB_SITE/files/$TARBALL"
    2.18 +WGET_URL="${WEB_SITE}files/$TARBALL"
    2.19  
    2.20 -DEPENDS="libcrypto openssl glib gpgme libgpg-error  ncurses"
    2.21 -BUILD_DEPENDS="ncurses-dev glib-dev"
    2.22 +SUGGESTED="mcabber-help"
    2.23 +DEPENDS="glib gpgme libasyncns libcrypto libgpg-error loudmouth ncurses openssl"
    2.24 +BUILD_DEPENDS="glib-dev libasyncns-dev loudmouth-dev ncurses-dev"
    2.25  
    2.26  # What is the latest version available today?
    2.27  current_version()
    2.28 @@ -23,14 +25,13 @@
    2.29  # Rules to configure and make the package.
    2.30  compile_rules()
    2.31  {
    2.32 -	cd $src
    2.33 -	./configure && make && make install
    2.34 +	./configure &&
    2.35 +	make &&
    2.36 +	make install
    2.37  }
    2.38  
    2.39  # Rules to gen a SliTaz package suitable for Tazpkg.
    2.40  genpkg_rules()
    2.41  {
    2.42 -	mkdir -p $fs/usr
    2.43 -	cp -a $install/usr/bin $fs/usr
    2.44 +	cook_copy_folders	bin
    2.45  }
    2.46 -