wok rev 24283

updated scummvm (2.1.2 -> 2.5.1)
author Hans-G?nter Theisgen
date Wed Jan 12 15:42:09 2022 +0100 (8 months ago)
parents 818db3c96a15
children 595388de14c6
files scummvm/description.txt scummvm/receipt
line diff
     1.1 --- /dev/null	Thu Jan 01 00:00:00 1970 +0000
     1.2 +++ b/scummvm/description.txt	Wed Jan 12 15:42:09 2022 +0100
     1.3 @@ -0,0 +1,15 @@
     1.4 +ScummVM is a program which allows you to run certain classic graphical
     1.5 +adventure and role-playing games, provided you already have their data
     1.6 +files.
     1.7 +The clever part about this: ScummVM just replaces the executables
     1.8 +shipped with the games, allowing you to play them on systems for which
     1.9 +they were never designed!
    1.10 +ScummVM is a complete rewrite of these games' executables and is not an
    1.11 +emulator.
    1.12 +
    1.13 +ScummVM supports a huge library of adventures with over 250 games in total.
    1.14 +It supports many classics published by legendary studios like LucasArts,
    1.15 +Sierra On-Line, Revolution Software, Cyan, Inc. and Westwood Studios.
    1.16 +Next to ground-breaking titles like the Monkey Island series, Broken Sword,
    1.17 +Myst, Blade Runner and countless other games you will find some really
    1.18 +obscure adventures and truly hidden gems to explore.
     2.1 --- a/scummvm/receipt	Tue Jan 11 18:14:39 2022 +0000
     2.2 +++ b/scummvm/receipt	Wed Jan 12 15:42:09 2022 +0100
     2.3 @@ -1,7 +1,7 @@
     2.4  # SliTaz package receipt.
     2.5  
     2.6  PACKAGE="scummvm"
     2.7 -VERSION="2.1.2"
     2.8 +VERSION="2.5.1"
     2.9  CATEGORY="games"
    2.10  SHORT_DESC="A 'virtual machine' for several classic graphical point-and-click adventure games."
    2.11  MAINTAINER="admin@trixarian.net"
    2.12 @@ -11,8 +11,8 @@
    2.13  TARBALL="$PACKAGE-$VERSION.tar.xz"
    2.14  WGET_URL="${WEB_SITE}frs/$PACKAGE/$VERSION/$TARBALL"
    2.15  
    2.16 -DEPENDS="alsa-lib flac gcc-lib-base libmad libmpeg2 libogg libsdl2 libvorbis zlib"
    2.17 -BUILD_DEPENDS="alsa-lib-dev flac-dev libmad-dev libmpeg2-dev libogg-dev \
    2.18 +DEPENDS="alsa-lib flac gcc83-lib-base libmad libmpeg2 libogg libsdl2 libvorbis zlib"
    2.19 +BUILD_DEPENDS="alsa-lib-dev flac-dev gcc83 libmad-dev libmpeg2-dev libogg-dev
    2.20  	libsdl2-dev libvorbis-dev zlib-dev"
    2.21  
    2.22  CROSS="bug: Doesn't support --build."
    2.23 @@ -20,6 +20,9 @@
    2.24  # Rules to configure and make the package.
    2.25  compile_rules()
    2.26  {
    2.27 +	export	CC=gcc-83
    2.28 +	export	CXX=g++-83
    2.29 +
    2.30  	./configure				\
    2.31  		--prefix=/usr			\
    2.32  		--datadir=/usr/games/scummvm	\
    2.33 @@ -32,7 +35,7 @@
    2.34  	make install &&
    2.35  	{
    2.36  	mkdir -p $DESTDIR/usr/share/applications
    2.37 -	cp -a dists/scummvm.desktop	$DESTDIR/usr/share/applications		
    2.38 +	cp -a dists/scummvm.desktop $DESTDIR/usr/share/applications		
    2.39  	}
    2.40  }
    2.41